夜间模式暗黑模式
字体
阴影
滤镜
圆角
主题色
解决OpenWrt Lean源码5.4内核 UPnP编译后无法使用的问题

上一次编辑:

2020/07/29 编辑:问题已修复,删除源码重新编译即可

由于lean的软件包内 UPnP版本太新了 所以用不了了

解决办法有两个

1 用老源码 编译20170421版的upnp 然后通过ipk安装(要装三个ipk:luci-app-upnp, miniupnpd, luci-i18n-upnp)老源码:https://github.com/coolsnowwolf/openwrt

2 用新源码 然后替换upnp为适配与5.4内核的版本 (解决方法来自https://github.com/coolsnowwolf/lede/issues/5020 @zmzhuai

cd feeds/packages/net

wget https://github.com/zmzhuai/R2S-OpenWrt/raw/old-miniupnpd/miniupnpd.tar.gz

tar -xzvf miniupnpd.tar.gz

然后make menuconfig重新编译即可

暂无评论

发送评论 编辑评论


				
上一篇